How to Solve IE9 Problem of Opening link in New Tab/Window

Whenever i was trying to open any link in new window/tab, I was getting a blank idle tab. I was facing this problem for last few months but finally got solution which i wanted to share with you guys. I’ve tried these following solutions but none was able to solve it.

I’ve tried:

  • Tried using IE9 with “no add-ons” mode
  • Rolled back to ie8 & then re-install IE9 again
  • Reset default settings from Advanced Internet Options
  • Deleted temporary Internet files, cookies, history… etc.
  • Used “Microsoft fix it”
  • & also tried “cmd” file from Microsoft that solves such problems “ie8-rereg.32on64.

Solution:

Follow these methods:

Method 1:
Step 1: Boot into safe mode with networking and see if the issue persists.

See Advanced start-up options (including safe mode) for instructions on booting into safe mode with networking.

Note: Wireless connection may not work in safe mode with networking. I’d recommend you to use the wired internet connection in safe mode with networking.

Step 2: If the issue does not occur in safe mode, boot your system in a clean boot state (in normal mode) to troubleshoot the issue.

See How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

Note: After troubleshooting, ensure to set the computer to start as usual as mentioned in Step 7 in the above KB article.

Method 2:
Access the following link and refer to OnyXxL’s response posted on Wednesday, November 11, 2009 to fix the issue:

http://social.answers.microsoft.com/Forums/en-US/InternetExplorer/thread/e312e580-1cbc-496b-8c6b-b69b8535a7bb

Advertisements